No announcement yet.

Mesh Export Problems

  • Filter
  • Time
  • Show
Clear All
new posts

  • Mesh Export Problems

    I cannot find any option to get over the current problem I have which is that every mesh that I export (textured, non-textured) is exported with a ton of unmerged vertices.

    This means that it's (almost) impossible to remesh the high poly inside Zbrush, and very time-consuming to import and merge verts inside Maya.

    The other problem, is that OBJ models get exported with a -90 rotation on the X plane.

    So, what am I doing wrong here? Help would be greatly appreciated!

    Click image for larger version

Name:	Screenshot 2023-02-14 121226.png
Views:	268
Size:	118.5 KB
ID:	8750Click image for larger version

Name:	Screenshot 2023-02-14 121354.png
Views:	271
Size:	192.0 KB
ID:	8752
    Attached Files

  • #2
    Hey JayCobb -

    Different programs have different default up-axis, you can change the up-axis in Zephyr through Tools>Options>Application>Up-Axis

    As for the model itself - Can you please let us know what kind of settings are you using for mesh creation & export? Ideally if you can share the images + project (.ZEP) through a file sharing service like Google Drive that will speed up troubleshooting a lot! You can either post the download link here or send it privately to and we can pick it up from there.


    • #3
      Thanks a lot for the response. I'm unable to share the project file due to a current NDA, but the mesh has been created with the standard surface reconstruction presets of General and Default. Even if I decimate, retopolgize etc. it still produces a mesh with unmerged vertices.


      • #4
        Hi JayCobb,

        this sounds more of an import issue. Which software are you trying to load the 3DF Zephyr output into? Zbrush only or other software? I'm not aware of compatibility issues with Zbrush. Could you also share the 3DF Zephyr version you are using please?

        Can you try loading the output model into for example blender, to verify that this is not an export issue?

        Some things you can try:

        - lower the triangle count. Some software have difficulties handling big mesh.
        - export in local coordinates. Some software have difficulties with double precision.
        - try a different export file format


        • #5
          Thanks for the suggestions. I have tried each of them with the same result, so it's definitely not an export issue.

          If I export the decimated or original mesh, it does however give me exactly the same amount of meshes when separated in Maya, which leads me to think that perhaps the original mesh got screwed up some how.

          I really can't start from scratch though as it's structured from 5000+ photos, took about 48 hrs to generate the clouds and I've only got a few days left of a trial licence (6.513) to figure out if this program is going to offer any advantage to us over RealityCapture. So would really appreciate any other possible suggestions. Thanks.


          • #6
            Feel free to reach out to and I will be happy to send you an extension

            Is there any chance you could try a test dataset for us? This way we can verify if it's something that happens regularly or if it's something specific of your project. For example take few photos of whatever you have around, and see if the problem persists? Thanks!

            If it's a bug it's a test that will certainly make us aware of it. We also changed a lot of stuff in the upcoming 7.0 release, I'll be happy to send you an invite in case you want to try that as well, though I don't think any interoperability change should make the export work magically.


            • #7
              OK, thanks once again for your help. I have many other datasets which I've ran successfully through other photogrammetry software, so I'll test one of those and get back to you on trying to replicate the problem.


              • #8
                Ok. Have had some time to run a test mesh which came out without any problems. I've checked it in Maya and it's all one solid mesh with merged verts. This gives me a good retoplogy within Zephyr as you can see with the first screenshot. The second one is from the original mesh with a retopology applied, where you can see the triangles intersecting with each other which I'm guessing is from the unmerged vertices.

                Click image for larger version

Name:	Screenshot 2023-02-16 104541.png
Views:	233
Size:	386.1 KB
ID:	8762Click image for larger version

Name:	Screenshot 2023-02-16 104716.png
Views:	235
Size:	352.4 KB
ID:	8763
                Attached Files


                • #9
                  Hi JayCobb,

                  thank you for the test!

                  I've seen similar artifacts very rarely in the past, in a lot less amount, and only when the mesh was being generated by clearly wrong oriented photos (and from your initial screenshot it seems the SfM phase is fine but it's always difficult to assess via a screenshot especially with many cameras) so I'm a bit puzzled. Maybe I'm missing something about your workflow that could be the culprit?

                  - Have you created smaller meshes and merged them together , or is this coming from one reconstruction only? Merging meshes within the workspace will keep intersecting triangles as it's a simple merge-mesh, thought I don't think this is the case judging from the screenshot, I thought I'd mention this.

                  - Are you using external geometry source (e.g. laser scanner) along with photogrammetry? If so could you share your workflow?

                  - I believe that the issue is present in the original mesh that has been generated, rather than an issue in the retopology filter. Could you please confirm if you see this problem in the original mesh before retopology please?

                  I'm afraid I can't be more specific without taking a look at the dataset. As I mentioned I've never seen this problem at such a big scale so it would be very interesting for us to check this dataset, though I understand you can't share it via NDA, we'd be happy to take a look if you are able to reproduce it with another dataset.

                  Thank you!


                  • #10
                    Ok, well thanks a lot for the help with the limited information I am able to give. I have generated another mesh entirely from the beginning, with the same results.

                    In answer to your questions, this is one single mesh generated from 5023 photos. Not separate merged projects, nor multiple sources. Just extracted photos from a drone video.

                    I'm running it as per the instruction manual, using the presets throughout each step but it seems no matter what I do that the verts are not being merged which results in impossible retopology with intersecting vertices and non-manifold geometry as you can see in the attached screenshots.

                    But, perhaps it is the decimation which is failing to merge the verts, it's difficult to tell from the original mesh but it seems to be good (last screenshot).

                    Click image for larger version

Name:	Screenshot 2023-02-16 200606.png
Views:	222
Size:	160.4 KB
ID:	8769Click image for larger version

Name:	Screenshot 2023-02-16 211146.png
Views:	219
Size:	281.3 KB
ID:	8770Click image for larger version

Name:	Screenshot 2023-02-17 132033.png
Views:	209
Size:	457.8 KB
ID:	8771
                    Attached Files


                    • #11
                      Thank you for the followup!

                      We'll try to reproduce this scenario internally and investigate the issue.

                      If this same issue appears again in a dataset you can share with use, please feel free to reach out anytime at - this will help us pinpoint the cause and fix it.

                      If by chance you are able to send this current dataset in the future (e.g. NDA terms changes) please feel free to reach out, likewise.

                      I can also send you a beta for the upcoming 7.0 in case you want to give it a shot.

                      Eventually you can try and share us a small part of the mesh (before and after) ? I'm not sure there will be enough information for us to work with but that would be better than nothing


                      • #12
                        Thanks again, really appreciate the help but unfortunately I'm left with models which I can't do anything with outside of 3D Zephyr. I'd like to try to run this with the beta to see if I get the same results, so would appreciate the invite offered.


                        • #13
                          Sounds good, sending you an invite in private!


                          • #14
                            Well, I tried to run the process again using the beta and after several hours I get a "something went wrong" message. First time produced a partial point cloud, second time nothing at all which I'm assuming is from the memory running out. When I try to run the mesh extraction, I get the message that this machine does not have enough RAM to run the computation. Which whilst it isn't the recommended system requirement of 32GB, I do have the minimum 16GB.

                            The retopolgy filter seems to work for the most part on this model however, but still creates a lot of intersecting triangles which I can't figure out why. At least this seems to give me a model which I can actually remesh inside zBrush though.

                            Click image for larger version

Name:	Screenshot 2023-02-21 095509.png
Views:	206
Size:	29.4 KB
ID:	8780Click image for larger version

Name:	Screenshot 2023-02-21 100052.png
Views:	211
Size:	67.6 KB
ID:	8782
                            Attached Files