Announcement

Collapse
No announcement yet.

GPU driver issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • GPU driver issue

    Trying out the trial version of 3DF Zephyr Lite 2.250

    When I start the software it tells me my drivers are out of date and defaults to CPU mode.

    I am running an Nvidia TitanX running driver version 361.75 (released about 5 days ago).

    Any way to force it to use the GPU? Or please let me know what drivers I should be installing...

  • #2
    Solved this, it needed the latest Cuda drivers.

    Looking forward to trying out the software...

    Comment


    • #3
      Hello Derek!

      there is actually a known bug in 2.250 that sometimes report incorrectly recent enough drivers as old. Anyways yes, Cuda7 is required for that build. We will push 2.300 very soon that should fix that bug anyways!

      By the way, even if you see that message but you see your card in the cuda options then you're fine! Glad to hear you fixed it already anyways!

      Looking forward to hear your feedback on Zephyr! Cheers!

      Comment


      • #4
        I am having a similar issue however the card in the cuda options does no show up. I have updated the drivers to the most current and still they do not show up. Is the NVIDIA Quadro FX 4800 compatible with 3dF Zephyr Pro 2.308?

        Comment


        • #5
          Hello Johnathan,

          by a quick google search it looks like the quadro FX only has Cuda capabilities 1.3, while zephyr requires at least Cuda 2.0 capabilities to run (at least a Fermi architechture chip https://en.wikipedia.org/wiki/CUDA)

          I'm sorry to confirm that you won't be able to run Zephyr in GPU acceleration with that hardware

          Andrea

          Comment


          • #6
            Andrea,

            Thanks you for the quick response. Although it's bad news it's at least news and I can move forward. Looks like we will have to find a new card.

            Thanks for your time,

            J.

            Comment


            • #7
              You're welcome!

              Just make sure you have Cuda ] 2.0, however if you need confirmation for a specific card you're looking into, feel free to ask!

              Andrea

              Comment


              • #8
                hello,

                i need some help also if you have the time.

                i started the zephyr lite trial a while back, and i liked it enough to buy an old nvidia tesla card for the cuda acceleration. it is the m2090 with a fresh driver.

                before the tesla card, zephyr ran well. slow, but stable.

                after i installed the tesla card, it appeared in the options>cuda tab like it should, but when i attempted a sparse point reconstruction, zephyr went for a few hours, then stopped during the multi match step 3/4. after restart, it would not show the tesla card in the cuda options like it did before. rebooting the computer has no effect, but removing the tesla card, rebooting, replacing the tesla card and rebooting again DOES work, once.

                the second sparse point attempt had the same results.

                please help, i only have a day or two left on the trial to figure this out. tonight, i am going to run an exhaustive sparse point reconstruction
                on just the cpu to see if it still is stable like it was before
                thanks,

                michael


                computer:
                intel i7 6700k
                24gb ram
                windows 10
                r9 390, for the display
                tesla m2090, for the math with nvidia driver 354.92
                asrock z170 exteme4 mb

                Comment


                • #9
                  Hi Mike,

                  although it's not very recent, the m2090 should work with Zephyr with no issues. However, it looks more of a system issue to me, since it should show the card after the reboot.

                  I'll gladly help you out figuring what the issue is! Can you please send me the logfile? Don't worry about your trial, i can give you an extension while we figure out what your problem is.

                  May i get in touch at the email address you used to sign up to the forum?

                  Andrea

                  Comment


                  • #10
                    thank you!

                    i'm at brewinmike@gmail.com

                    last night, after i started sparse point reconstruction with the tesla and it had stalled, i looked in device manager and the tesla card was still there and "working properly" according to windows. however, this morning it doesn't show up in device manager...

                    i have about 2 and a half hours left on the cpu only sparse point reconstruction that i started last night to use as a control, and its still running smoothly. if it crashes, ill post the log file from that. if it successful, ill try it again with the tesla and post that log file here.

                    i'll be looking into why my tesla card is disappearing, i'll be back here soon.

                    thanks again,

                    michael

                    Comment


                    • #11
                      No problem!

                      I followed up via email with another trial key so that you have more time to test it out.

                      Andrea

                      Comment


                      • #12
                        thanks a million!

                        i'm making progress too. i can't copy the log because when the tesla drops out and i abort the run, the program stops responding, and i have to end the process in task manager. i'm sure there's another way, but i'm a newbie, i haven't learned it yet

                        the log says "symmetric matching pair imgxxx<->imgxxx..... cuda device: tesla m2090"
                        or "symmetric matching pair imgxxx<->imgxxx..... cpu/sse2"

                        or something like that. it whizzes by awfully fast.

                        when the tesla drops out, all the
                        "symmetric matching pair imgxxx<->imgxxx..... cuda device: tesla m2090"
                        lines stop appearing and all you see are the
                        "symmetric matching pair imgxxx<->imgxxx..... cpu/sse2"

                        i also learned, when you don't see the cuda lines in the log anymore, open device manager, right click, scan for hardware changes, and the tesla will disappear. i can't find the page again, but i learned how to set devmgr to show hidden hardware, than i could see in the hidden tesla cards properties that the computer thought it was physically disconnected.

                        so, i open up the case, and the tesla card is HOT.

                        hot enough to make the r9 seem comfortable, and the r9 will leave an awful burn if you touch it during an extended fallout4 session

                        more reading shows that the tesla cards that nvidia made that don't have an integral fan often run very hot, and shut themselves down at 106c.
                        i started sparse point reconstruction again, and as i expected, when the temperature got near boiling, i didn't see any more

                        "symmetric matching pair imgxxx<->imgxxx..... cuda device: tesla m2090"

                        lines in the log.

                        you were correct: it was a hardware problem. it was an "nvidia should have installed a fan on it from the factory" problem to be precise.

                        looks like my next step will be 3d printing some kind of manifold to force air through the teslas heatsink, and if that doesn't work, there are a plethora of five year old threads on the internet on how to watercool the tesla m2090...

                        either way, sometime soon i will be a happy zephyr user! well, i'm a happy zephyr user now. i'll be a happy tesla user sometime soon. when it runs, it freaking RUNS. when i find an easy way to keep the telsa cool, i'll try to remember to post it here. they're only $99 on ebay, i bet that soon alot of people that run zephyr just on the cpu will start buying them

                        thanks again,

                        michael

                        Comment

                        Working...
                        X