Announcement

Collapse
No announcement yet.

Export to textured mesh doesn't work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Export to textured mesh doesn't work

    Using the export to textured mesh .obj format doesn't work.

    I work in webvr so you are limited to working with .obj and .mtl files. If you try to use the files directly you get errors about unexpected vertex/normal/uv lines. And it's the same for WebGL, ThreeJS and aFrame.io

    Trying to import the .obj file into blender also comes up with the same kind of errors.

    The only workaround I have found so far is to export from Zephyr as .fbx and them import the .fbx into blender and then export from blender as .obj, which is a total pain.

    Is the zephyr team aware that their .obj files don't import into standard software like blender?


  • #2
    Hello mrLoganite,

    sorry about your issue. Do you think you could share with me one of the exported OBJ from zephyr that does not load into blender ?

    Also, which version of Zephyr are you using? Zephyr supports objs (and many other format) that work with blender, so either you found some bug in zephyr (which is possible but i need the obj to further investigate) or there are some limits in the libraries you are using (i personally don't know webvr but it looks like an experimental library) for example in the number of vertices.

    If you can share one of the objs that are giving you issues i will gladly investigate why you can't load it into blender!

    Andrea

    Comment


    • #3
      Hi,
      They all fail. I bought the lite version a couple of days ago and I have generated textured meshes from multiple subjects and none of the .obj files will import into the current version of blender and non of them can be used with any version of aframe or threejs.

      But it's easy for me to send you one, I will dig one out , how do I get the file to you?

      Comment


      • #4
        Pretty odd, i am also using 2.77a .

        Do you think you can send me both

        - the zep files and pictures of a dataset
        - one problematic obj exported from said zep file

        please?

        you can send me via wetransfer, dropbox or google drive at support@3dflow.net ! (or if you'd like another way, do you mind if i contact you at the email you used to sign up at the forum?)
        Last edited by Andrea Alessi; 2018-12-11, 02:08 PM.

        Comment


        • #5
          ok, I shared it with google drive. I don't have the zep files as I tend to throw them away after I get the mesh so I might have to make another example.

          Comment


          • #6
            ok I shared another smaller example, same errors, don't have the zep file for this either, sorry.

            Comment


            • #7
              looking deeper into the errors on blender it complains about entries in the zephr mesh file like this

              vn -1.#IND00 -1.#IND00 -1.#IND00

              there seems to be quite a few of them output by the zephr export processes and blender expects numbers, is any of this relevent?

              EDIT: looking at aFrame an ThreeJS errors they also seem to be complaining about the same lines. Perhaps I found a bug


              Comment


              • #8
                Thanks!

                Hmm, probably there isn't a sanity check when exporting a normal, althought it's not supposed to ever generate that type of value.

                If you get another zep/dataset with the same issue, could you please keep it and share it with us?

                Comment


                • #9
                  Before buying the real version I tried the 14 day trial version on a couple of different machines and encounted exactly the same issue, I had expected it to be fixed in the proper version and was supprised that it had the same problem.

                  Update: just tried another one (its very large sorry) and it has exactly the same problem. So I will try to get all the images, .zep file and meshes together so that you can look at it.

                  Comment


                  • #10
                    that'd be wonderful, thanks!

                    Comment


                    • #11
                      ok, its all yours.

                      let me know when there is a fix, thanks.

                      Comment


                      • #12
                        Hi mr. Loganite!

                        Thanks for reporting this! We have already added a fix in our development version and the NaN normals have been corrected. The fix will be included in the next beta (next week) and in the next stable release (eta end of July). If you are interested in testing the beta version, Andrea (knu) can sign you up.

                        Comment

                        Working...
                        X