Announcement

Collapse
No announcement yet.

Cant run CUDA on the latest 3DF Zephyr v v4.530

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cant run CUDA on the latest 3DF Zephyr v v4.530

    Hi,
    I am running 3df Zephyr v4.530+(x64) on windows 8.1 x64. I have an NVIDIA TitanXp card with the latest drivers (v445.87). I also have cuda 9.0 and cuda 10.0 sdks installed.The 3DF Zephyr however says there is no CUDA capable card when my card is compute capability of 6.1 which is enough I guess. The log is attached. Please help.

    Regards,
    MMMovania

    EDIT:
    I managed to find the issue. Basically, I am using a python library that uses tensroflow API to do machine learning on the GPU. That library required setting an environment variable CUDA_VISIBLE_DEVICES=-1 to disable GPU code and CUDA_VISIBLE_DEVICES=0 to enable device 0 GPU. I edited that environment for comparing performance of the CPU code against the GPU code but it was left as CUDA_VISIBLE_DEVICES=-1. This disables access to CUDA in any application that tries to access it. This was a new news for me. I removed the CUDA_VISIBLE_DEVICES environment variable and then restarted zephyr and it worked
    Attached Files
    Last edited by mmmovania; 2020-05-19, 09:59 PM. Reason: Solved the issue

  • #2
    Hi mmmovania, thank you for sharing the fix, hopefully this will help other people as well!

    Comment

    Working...
    X