Announcement

Collapse
No announcement yet.

Having trouble with Masking by colour

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Having trouble with Masking by colour

    I have recently started using Mask by colour and have found it a great way to easily mask photographic subjects. My present setup is a Canon 60 D DSLR with a 28-135 mm Canon lens with usm and image stabilisation. This is mounted on a Manfrotto tripod using a pan and tilt head. The thing being photographed sits on an ikea lazy susan that does service as a manual turntable. This in turn sits on a chest of drawers.Both the turntable and the backdrop are covered in semi matte black paper. This has worked out so far and I managed to create a 360 degree model of a chunk of rock that I was pleased with. This model was made up of 430 odd photos and these were all masked by colour.

    Since that success I went on to photograph a small brass sculpture. The brass was shiny and the autofocus rendered the background as a mid grey. After shooting a run of photos these were imported into Zephyr Lite 4.530 on my windows 10 pc and an attempt was made to mask by colour using Masquerade. I adjusted the Threshold and Gauss iteration values but could not get the masking to work. It eventually dawned on me that my camera's autofocus was being confused by the shiny reflective brass sculpture.This was resulting in the black backdrop being shown as a mid grey tone rather than black. This led me to coat the sculpture in Chalk spray so as to get rid of the reflections.This gave me back my black backdrop but it did not solve the situation. Masquerade would recognise the imported images but not allow the mask to be created. I can click on the Mask by colour icon at the bottom of the screen and use the colour picker tool to select the black background and then click Apply but the sculpture does not turn red. Clicking on the b/w mask icon at the top of the screen causes the editor screen to go black and the image loaded into the editor disappears. Clicking on the b/w mask icon a second time brings back the image but it looks like I have done something to mess with the Mask by colour function. It is possible to proceed to the Sparse point cloud generation phase but although it runs and finishes, it ends up with an empty Sparse point cloud. There is nothing visible on screen, and the project panel states that zero cameras were used. I had wondered if there was a sparse point cloud produced but not visible for some reason but the zero cameras used seems to say no.
    Last edited by 3DEnthusiast; 2020-05-31, 03:12 PM.

  • #2
    Hi 3DEnthusiast

    Glad you have recently found success masking by colour in Masquerade - To be able to give you targeted feedback on your unsuccessful attempt we will need to see the dataset in question.

    What are your current Mask by Colour settings? I currently use Threshold: '0.10' & Gauss Iter.: '0' which provide perfect separation for my images-

    Click image for larger version  Name:	Capture.JPG Views:	0 Size:	88.9 KB ID:	6314


    Ps. If your camera/lens combination are struggling to find focus, I would highly recommend turning off autofocus and setting your focus manually - This way you eliminate a moving part from the process and are less likely to have problems later down the line.

    Comment


    • #3
      Hi Cam3d,

      On re-reading my original post, I realised that I had stated that my camera's autofocus was being confused by the shiny brass, but of course it was the auto white balance that was having trouble. Sorry about that. The autofocus managed alright. My fault was in not paying any attention to the Threshold value or the Gauss iteration values when I started using Mask by colour. These were just left as they were and they worked fine until my attempt to photograph a shiny brass object. Because I had never paid any attention these values I had no idea what the original settings were and stumbled all over the place getting more lost in the process.

      Your timely intervention has steered me back onto the pathway and I have managed to mask a 73 shot run of photos around my diminutive brass baby sculpture using the settings in your post and send it off for processing. This turned out alright and I also learned the answer to another thing that had been perplexing me about cleaning up noise at the Sparse point cloud stage. I have been in the habit of deleting unwanted stands or supports via manual selection and being confused when they show up again when I get to the Dense point cloud stage. I have just realised that what I need to do is reduce the size of the Bounding box to exclude these unwanted supports. Oh, well, every day is a school day,

      Thanks again.

      Comment

      Working...
      X