Announcement

Collapse
No announcement yet.

compile error about FlowEngineFreeLinux64_5019

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • compile error about FlowEngineFreeLinux64_5019

    When I built FlowEngineFreeLinux64_5019 on Ubuntu 16.04 as the following link says ?
    file:///media/zeng/work/FlowEngineFr...tallationLinux

    Errors occur as shown in the following:

    Click image for larger version

Name:	Screenshot from 2021-04-27 16-11-08.png
Views:	48
Size:	219.1 KB
ID:	7319
    Could you please give me a hand?Thanks very much!

  • #2
    Dear FlowEngine team?
    I downloaded the FlowEngineFreeWin64_5019 on windows10-64bit system for free. When I ran the code of "ExampleBasic.cpp” on microsoft visual studio 2017? errors occur as follows?
    Severity Code Interpretations File Line
    error(Activity) E0035 #error instruction: "Unsupported Platform!" Common.h 92
    error(Activity) E0020 Undefined identifier "ti" Common.h 143
    I do not know how to solve this problem. Could you please give me a hand?Thanks very much!
    Yours sincerely,
    Letian Zeng

    Comment


    • #3
      Hi,


      you are missing imagemagick

      make sure to compile it with the options described in the readme

      for example

      apt-get install -y libpng-dev libjpeg-dev libtiff-dev && \
      tar -xvf ImageMagick.tar.gz && \
      cd ImageMagick-7.* && \
      ./configure --with-quantum-depth=16 --enable-hdri=yes CXXFLAGS=-D_GLIBCXX_USE_CXX11_ABI=0 && \
      make -j8 && \
      make install

      then make sure to run ldconfig or have imagemagick point to the right library if you have multiple versions installed

      Comment


      • #4
        Hi,
        You must run cmake and target x64 architectures, also I suggest using VS2019

        Comment

        Working...
        X