Bug with Zephyr Lite Version 7 and Masquerade ???

Collapse
X
 
  • Time
  • Show
Clear All
new posts
  • pdussart
    3Dfollower
    • Jul 2022
    • 20

    Bug with Zephyr Lite Version 7 and Masquerade ???

    Sir,

    I just began to test Zephyr Lite Version 7.
    I agree that generated meshes are better and more precise, speed increased, etc. It looks like a good upgrade.

    I made a test where I combined 2 photo shoots of the same object.
    Part of the pictures were masked by Masquerade Version 6.5 (some months ago), part of the pictures masked with Masquerade 7.0 (today)
    The results are not usable.
    Both Masquerade files are distorted while using Zephyr Lite version 7

    See 2 attachments. This is what you see within Zephyr, after mesh generation.

    All Masquerade pictures version 6.5 show the same distortion: the upper right corner is like "pulled" with a dot in the corner
    All Masquerade pictures version 7 show the same distortion: the upper right corner is like "squeezed"

    Note 1: the same camera was used. Nikon D750.
    For the Masquerade version 6.5, a Sigma good zoom was used
    For the Masquerade version 7, an excellent Sigma 35mm was used.

    Note 2: If I use only one "type" of Masquerade files, no problem with Zephyr 7 results.
    May be the mix of lenses provokes this lens profile problem

    Regards, Philippe
    Attached Files
    Last edited by pdussart; 2023-03-04, 11:10 AM.
  • Andrea Alessi
    3Dflow Staff
    • Oct 2013
    • 1297

    #2
    HI pdussart,

    it's hard to tell from these screenshots alone what's going on - could you please share with us the dataset (photos and masks, and eventually, also the full zep and _files subdirectory?) so we can have a look?

    Thank you!

    Comment

    • pdussart
      3Dfollower
      • Jul 2022
      • 20

      #3
      Andrea,

      OK, but it is big. How to do this ? Wetransfer ?

      Regards, Philippe

      Comment

      • Andrea Alessi
        3Dflow Staff
        • Oct 2013
        • 1297

        #4
        Hi Philipphe,

        whatever works best for you - a wetransfer to support@3dflow.net works for us

        Comment

        • pdussart
          3Dfollower
          • Jul 2022
          • 20

          #5
          Andrea,

          the transfer of 1,5 GB has started a few seconds ago. It should be complete by 19h30 or so.

          Please note that there are two .zep files, one with options Fast/low details, one with deep/high details.

          In both cases the images are distorted, but in a different way.

          The older set of pictures does not contain good images of the top of the signal that I am trying to model (photo shoot in 2022 with a Sigma zoom)
          It was my first test with Zephyr.
          I realised that the top part of the model was not good enough (blur + not enough pictures + exposure was not optimal)

          I have taken a second shoot by mid February 2023. The issue is that the base of the model has been damaged since last year.

          I am trying to combine older pictures (overall = base + top) + new detailed pictures (the top without base)

          Note: I get better mesh results with Zephyr 7 (better algorithm and better lens used)
          If necessary, I will use a tool to sculpt the mesh generated by version 7.

          Regards, Philippe

          Comment

          • Andrea Alessi
            3Dflow Staff
            • Oct 2013
            • 1297

            #6
            Hi Philippe,

            the fact that the photos are distorted in the workspace is "normal", meaning that the distortion itself is not a symptom of an issue.

            You don't want to mask such a dataset in most cases, and definetly not in the SfM phase - you want to use all the information in the photo especially for the camera orientation. You can eventually load the masks after the SfM, but give that your subject is still, masking the images is not necessary.

            By masking the images you're making autocalibration harder, and that is why it gets to an excessive distortion. From your message it also seems like you used two separate lenses, but I don't see this information in the exif. It is possible you delete some exif information if you did pre-processing (e.g. in photshop) and this is something that you should always avoid, as that will feed zephyr misleading information that can cause problems.

            By not using masking in the SfM and the loading the masks after the SfM phase was completed (from tools > workspace > change masks) you are effectively aiding zephyr in the orientation phase since it has context to use.

            For such thin surfaces (when you are taking a sideways picture) this is generally very important. Additionally, I suggest taking more photos, try doing a couple of orbits and getting closer between each orbit - zoom photos can indeed be used but try to keep a "chain" of photos to aid zephyr as much as possible.

            Hope this helps

            Comment

            Working...
            😀
            😂
            🥰
            😘
            🤢
            😎
            😞
            😡
            👍
            👎