Having an issue with how the software is interpreting camera position

Collapse
X
 
  • Time
  • Show
Clear All
new posts
  • ngl1145
    3Dflower
    • Aug 2023
    • 5

    Having an issue with how the software is interpreting camera position

    Hello, I haven't had this issue previously. Recently I flew a DJI Matrice 30 and did a mapping run of a farm. I noticed that when the 3Dflow Zephyr software was rendering the land such there was an extreme curvature to it. I did have RTK enabled during flight. If you look at the image I posted, the rendering of camera in space location has an extreme curvature to it. How can I fix this? Can I fix this post rendering the project and have it correct itself?
  • cam3d
    3Dflover
    • Sep 2017
    • 665

    #2
    Hi ngl1145 - Thanks for letting us know!

    - Do you typically use the DJI Matrice 30 with no issue or are you using this specific hardware for the first time?

    - Are you doing any pre-processing of the images prior to processing in Zephyr?

    - What settings are you using for camera orientation in Zephyr (SFM)?

    If you like you can upload the photos + ZEP file (using WeTransfer or a similar file sharing website) and share a download link with us at support@3dflow.net. This way we can troubleshoot and identify issues more quickly :-)

    Comment

    • ngl1145
      3Dflower
      • Aug 2023
      • 5

      #3
      Thanks for getting back to me. I am using the Category "Aerial - Nadiral images" and default presets. I will send support@3dflow.net a zip file that contains all the images taken with the DJI Matrice 30. I've been using this drone for previous mapping and I did not notice an extreme curvature to the rendered map. It could also be that the farm was large and the curvature was more apparent. .

      Comment

      • cam3d
        3Dflover
        • Sep 2017
        • 665

        #4
        Hi ngl1145 - Thanks for sending through the images. I ran them myself with exactly the same settings (Aerial - Nadiral Defaults Zephyr 7.021 and had no issues with curvature (see attached image).

        If you go to Tools>Options>Application you can delete the temp directory - This could fix the issue. Also make sure you're using the most recent Zephyr release so we are on the same page for further troubleshooting :-)
        Attached Files

        Comment

        • ngl1145
          3Dflower
          • Aug 2023
          • 5

          #5
          Thank you for processing the files that I sent. I'm glad to see that you were able to get a flat render (which is what it should look like). I did confirm that I am running 3DF Zephyr Lite 7.021. I also went to Tools>Options>Application and deleted the temp directory. I'm still getting a warped perspective.
          Attached Files

          Comment

          • ngl1145
            3Dflower
            • Aug 2023
            • 5

            #6
            When it comes to the camera calibration step, did you touch anything or did you just use the defaults? When I did the last render, I didn't touch anything and it looks like a potato chip. I'm baffled by what is causing this. Each render takes a while to output the image so I feel like I'm burning a lot of time trying to create my image. I feel like it's a software setting.

            Comment

            • cam3d
              3Dflover
              • Sep 2017
              • 665

              #7
              ngl1145 - I just did a factory reset on my Zephyr installation and it worked fine, can you try that and see how it goes (Tools>Options>Application) - If it is still causing issues please send through the .ZEP project file so we can troubleshoot further.

              Comment

              • parkereveline
                Blossoming 3Dflower
                • Aug 2023
                • 1

                #8
                Hey there,
                RTK and software settings could be factors. Check RTK accuracy and software settings. Try post-processing tools to correct curvature, and ensure georeferencing accuracy. If needed, consult software support for specific guidance.
                ?

                Comment

                • noramila
                  3Dflower
                  • Aug 2023
                  • 8

                  #9
                  You can review and adjust the project settings, including camera calibration and alignment parameters. Tweaking these settings may help in achieving a more accurate reconstruction.

                  Comment

                  Working...