No announcement yet.

adjust user interface scale?

  • Filter
  • Time
  • Show
Clear All
new posts

  • adjust user interface scale?

    so my UI scale is too big and i cant see the bottom of the popups. see photo attached for example: the 'new project wizard' has a bunch of blank space before saying 'additional options at the bottom'. i cannot scroll down, i cannot move the window up. i can tab through options, but i have no idea what they are. i have tried generating a point cloud from photos but it keeps cutting off the bottom of my windows and i have no idea what settings are even down there. is there any way to adjust the UI scale? the only thing ive found is font size which is set to the default 12.

  • #2
    Hi vertigon,

    It look like you're running Zephyr on a very low resolution screen. In that case, try adjusting the dpi setting in windows.


    • #3
      Originally posted by Andrea Alessi View Post
      Hi vertigon,

      It look like you're running Zephyr on a very low resolution screen. In that case, try adjusting the dpi setting in windows.
      ? its a 47" 1080p tv, is that low resolution now? is the program entirely dependent on system dpi? it would be insanely inconvenient to have to adjust my system scale for ONE program, since i have things set specifically for personal visibility, and reducing it would make MOST of my system unreadable.


      • #4
        If you've scaled everything up then unfortunately also Zephyr's UI will be scaled accordingly, so you will have to downscale it to your liking. Either your screens is not set to 1920x1080 or your windows scaling setting is too large.


        • #5
          ok, so again, im not going to make system wide adjustments for ONE program that i havnt even gotten to work yet. since you havnt actually answered my questions let me see if i have inferred correctly: 3dflow does NOT have any scaling for its user interface. it IS entirely dependent on system scale. users with special visual accessibility settings should find a different program. is this correct?


          • #6
            Hi Vertigon,

            unfortunately, some dialog of Zephyr requires a minimum vertical resolution of 768 pixels (including scaling). You can increase the icons and font size from the options -> appearance menu, but currently, the software cannot run properly at a lower resolution. If you can not change the dpi of your screen, as a workaround, you may try to use the "quick project wizard" to create a new project or press "enter" to go to the next pages of the wizard. I hope this helps.


            • #7
              you should be aware that your 'solutions' are extremely unhelpful, and if i had legitimate visual disability i would instantly uninstall and never look back. your suggestion of reducing system scaling and adjusting the programs icon and font size would mean one of two things: either i regularly adjust my system scale every time i use this and only this software(cumbersome and annoying) OR i also adjust the UI scale on every other single piece of software that i use(since few developers presume to know what sort of setup the software will be run on or what adjustments might be made for the sake of ergonomics or accessibility) and just navigate the base system by standing up and walking over to the screen (also cumbersome and annoying). i already said that i can press enter and go through the new project wizard, upload images, and then it fails without visible explanation, just says try again with more photos or different settings. id like to play with settings before taking more photos, but without any way to resize those pop ups, or for them to just have a stupid scroll bar like every other piece of competently made software, i have no idea how to tweak settings. i apologize if i come across excessively hostile here, but after boiling it down to "yes/no that is correct/incorrect," you used a lot of words to say yes, my previous post is accurate


              • #8
                Yes, you are right. The interface cannot work below a 768 vertical resolution in some dialogs and wizard. We never had any issue reported on this till today. We should probably add scroll bars only when the screen resolution is low, to accommodate special visual accessibility. I'll report the problem internally and we'll check if it's possible to find a solution for the next updates. Thank you for reporting it.


                • #9
                  vertigon - Feel free to share any of your data-sets on the forum (through a google drive link or whatever your preferred method of file sharing is) - I'll happily advise how to acquire images with a high probability of 3D reconstruction success using the default settings (processing is typically much faster with the defaults)


                  • #10

                    Just a note to say that we have squeezed into the last minor patch, an option to remove the lower resolution bound. The option can be activated from the options->appereance menu:

                    Click image for larger version

Name:	reduce.JPG
Views:	406
Size:	28.7 KB
ID:	5390

                    Please let me know if this helps with your configuration.



                    • #11
                      I have the exact same problem. I have a new laptop, haven't adjusted any resolution settings on my computer. My screen resolution is by default 1920 x 1080. However when I open 3DF Zephyr, everything is huge and the buttons on dialogs are cut off. I don't have this problem with a single other program.

                      I've attached how the screen looks when I first open the program, and when I open the Options. You can see that the font and everything is enormous, very strange. Even after I clicked the checkbox "Reduce vertical size lower limit on dialogs" I still can't reduce the size of the popup window. I would have considered buying Zephyr but if I can't even get the program to have a reasonable UI that's out of the question.

                      Hope you can post a fix real soon!



                      • #12
                        Note: I am on Windows 10.
                        My temporary and suboptimal fix was to go to the program executable, right click, select "Properties", then under Compatibility>Change high DPI settings (see attached).

                        I checked off this box:
                        "Override high DPI scaling behavior. Scaling performed by:" and selected "System (Enhanced)". Now when I open the program it looks like the screenshot attached, much better.
                        Still, it's kind of annoying that I had to do this and it still feels like the fonts aren't crisp. Very hacky.

                        If anyone also has this problem and has a better solution I'd really like to know.