No announcement yet.

Hardware limits exceeded

  • Filter
  • Time
  • Show
Clear All
new posts

  • Hardware limits exceeded

    I have Zephyr Lite 7.021 and have been thrilled with the results in my first week of use. I had previously been experimenting for another couple of weeks with the free version.

    But now it gets right to the end of the process, gives me the message “Hardware limits exceeded. Textured Mesh 1 exceeds the hardware limits set in the Options (System tab) and will be rendered as a proxy object”. If I hit “OK” the error message disappears and I see the model, but in a single fluorescent green colour throughout. If I export the model (as a .glb) the resultis fine and the textured mesh has been correctly applied, but I can’t make any fine adjustments within Zephyr because I can’t see the model with the textured mesh applied while working within Zephyr.

    I have followed the advice within the error message, gone to the System tab and tried adjusting the limits in there, both up and down. There is no combination I can find that works.

    I am therefore wondering if there’s a limit within the Windows (10) OS itself, but I doubt this is the issue because it has been working fine for several days now: often with considerably larger numbers of images than what it’s now struggling with. I haven’t knowingly changed anything within windows settings.

    My system is using a Quadro P4000 GPU with a memory of 8,191Mb, a frequency of 1,480,000Khz and 14 processors.

    Any clues?

  • #2
    Hey HedStone3D - Glad to hear you have been enjoying Zephyr so far!

    Regarding hardware limits - Can you please share the relevant log file with us?

    This will help with troubleshooting :-)

    Best regards,


    • #3
      Wow, that was quick, thank you!

      This message won't let me upload a file ending in .flog How should I do that?
      But I have uploaded 3 images of the process.



      • #4
        Hey HedStone3D

        Thanks for the screen shots - You could email the file to or upload it somewhere and share the download link here :-)

        7.5m triangles isn't a massive amount so shouldn't been causing issues unless the hardware limits were mistakenly dropped.

        Can you share a screenshot of your hardware limits in the Zephyr options menu? Thanks!


        • #5
          Here are the hardware limits.
          I have previously been successfully using a Max Texture Size of 8192 x 8192.
          When this problem started happening I then tried 4096 x 4096 and even "No Limit". but neither worked.
          You'll therefore see that this time I set it to the ridiculously low 256 x 256, just to see what happened.
          Emailing you the log file now.


          • #6
            Hi HedStone3D

            Max texture size in the system settings is a total of all textures generated.

            In this instance your textured mesh settings allows up to 16x 8*8k images. This would theoretically be 16x more data than allowed with a 8x8k total hardware limit, but with the amount of image data you are inputting, you're not getting 16x 8*8k total, but you are getting more than 1x 8*8k which is why the limit has been reached.

            For simplicities sake I'd recommend using a single texture rather than multi-tile texture, and raising your system and texture mesh settings to 16/32k.

            Hope this helps!


            • #7
              Thanks Cam, I'll give it a go.

              1. Can you give me any guidance on when/where I ask for single texture rather than multi-tile?

              2. Can I retrospectively adjust that on my project which has already been through 99% of the process or would it be prudent to go back and start completely afresh?


              • #8
                HedStone3D You can set single or multi in the textured mesh generation presets or through the advanced texture mesh generation settings (top right of the textured mesh generation window).

                You can repeat the dense cloud, meshing and textured meshing as much as you like and flick between them in the project panel :-) No need for a full rebuild.


                • #9
                  Thanks so much for all your help today Cam, GREAT job!


                  • #10
                    No problem HedStone3D - Happy to help :-)